Ошибка выполнения luac: multiple Lua VMs detected. Expected 5.3 instead of 5.4

Страницы: 1
RSS
Ошибка выполнения luac: multiple Lua VMs detected. Expected 5.3 instead of 5.4
 
Здравствуйте!
Я установил lua 5.4.2
И, по аналогии с тем как было сделано для 5.3, произвел компиляцию lua-файла.
Запускаю скрипт luac из выпадающего меню "Запустить в Lua 5.4.1"
Получаю ошибку "multiple Lua VMs detected. Expected 5.3 instead of 5.4"
Насколько я понимаю, не существенно какая именно версия 5.4.1 или 5.4.2. Важно, что 5.4. Проблема скорее всего в другом.
Подскажите пожалуйста, почему при запуске luac возникает ошибка? И как её исправить?
QUIK 8.11.0.66

P.S. Проверил компиляцию 5.3. - Запускается! Работает! Но раз уж вы обновили луа, то подскажите как перейти на новую версию ))
Спасибо.
 
А без компиляции этот же Lua-скрипт - работает на Lua 5.4 ?
Дополнительные dll-библиотеки из проблемного Lua-cкрипта используются?
 
Цитата
swerg написал:
А без компиляции этот же Lua-скрипт - работает на Lua 5.4 ?
Дополнительные dll-библиотеки из проблемного Lua-cкрипта используются?
Без компиляции тоже не работает.
Ошибка аналогичная: multiple Lua VMs detected. Expected 5.3 instead of 5.4

Используется библиотека w32.dll в сборке под Х64. Для версии lua 5.3 эта библиотека отлично отрабатывает.
 
А говорите компиляция.
Сборки внешних библиотек надо брать для соотв. версии Lua.
https://quik2dde.ru/viewtopic.php?id=334
 
Цитата
swerg написал:
А говорите компиляция.
Сборки внешних библиотек надо брать для соотв. версии Lua.
https://quik2dde.ru/viewtopic.php?id=334
Спасибо!
Страницы: 1
Читают тему (гостей: 1)
Наверх