QUIK 8.0 x64: что нужно знать перед обновлением на новую версию

Страницы: Пред. 1 2 3 4 5 След.
RSS
QUIK 8.0 x64: что нужно знать перед обновлением на новую версию
 
Так же хотелось бы иметь экспорт в Wealth-Lab Developer, т. к. многие им пользуются для экспорта котировок в другие программы, например в Multichart.
 
Квик ни когда не поддерживал 64 битный режим, никто не планировал, что этот режим будет поддерживаться в будущем. А потом бац и весь написанный софт не работает под квик 8. По-моему просто не правильно так делать.
 
Цитата
Александр написал:
Квик ни когда не поддерживал 64 битный режим, никто не планировал, что этот режим будет поддерживаться в будущем. А потом бац и весь написанный софт не работает под квик 8. По-моему просто не правильно так делать.
Квик ни когда не поддерживал 64 битный режим, все планировали, что этот режим будет поддерживаться в будущем ...

более 90% ОС 64 битные на сей момент по замерам большинства стат. сервисов - в гугле забанили?

Кто эти ВСЕ? Не несите чушь.  
 
Цитата
Александр написал:
Квик ни когда не поддерживал 64 битный режим, никто не планировал, что этот режим будет поддерживаться в будущем. А потом бац и весь написанный софт не работает под квик 8. По-моему просто не правильно так делать.

Компании, которые формируют вокруг себя сообщество

отличаются от компаний,

которые пишут какой-то софт и продают его десятку брокеров.
 
Цитата
s_mike@rambler.ru написал:
Компании, которые формируют вокруг себя сообщество
имо, сообщества формируются не вокруг компаний, а вокруг идей или гибких и кастомизируемых продуктов, интересных энтузиастам или специалистам
именно так формируется сообщество вокруг открытых продуктов или продуктов с доп. доступом к документированному функционалу

РФ не имеет избытка финансовых и трудовых ресурсов при низком и ухудшающемся уровне образования
отсюда и вопли о "беде" при элементарных изменениях
очевидно, что "пострадают" наименее квалифицированные и амбициозные, но ...
раз уж у нас "типа каптиализм" , то нечего устраивать истерики - извольте соблюдать законы рынка (природы):
можешь - учись и делай, не можешь - заплати тому, кто может
нет можешь и нет денег - пнх.
 
Цитата
новичок написал:
Цитата
   s_mike@rambler.ru написал:
Компании, которые формируют вокруг себя сообщество
имо, сообщества формируются не вокруг компаний, а вокруг идей или гибких и кастомизируемых продуктов, интересных энтузиастам или специалистам
именно так формируется сообщество вокруг открытых продуктов или продуктов с доп. доступом к документированному функционалу

РФ не имеет избытка финансовых и трудовых ресурсов при низком и ухудшающемся уровне образования
отсюда и вопли о "беде" при элементарных изменениях
очевидно, что "пострадают" наименее квалифицированные и амбициозные, но ...
раз уж у нас "типа каптиализм" , то нечего устраивать истерики - извольте соблюдать законы рынка (природы):
можешь - учись и делай, не можешь - заплати тому, кто может
нет можешь и нет денег - пнх.
Во-первых,Новичок ты ошибаешься! Я использовал для передачи данных по сети luasocket, но для нее нет 64 битной версии. Весь код надо переписывать, тестировать и выводить в продакшин. И это не считая проблем, связанных глюками самого квика. Причем здесь капитализм или уровень профессионализма? И у моих колег такие же проблемы встали, переписать, тестировать полученный код. На это как минимум нужно время.
Во-вторых, Особого выигрыша переход на 64 битный режим квик не получит. Не понятно зачем это делать? От того, что операционные системы 64 битные, это не значит, что весь код должен быть 64 битным. Выигрыш от 64 битного перехода не особо виден.
 
Цитата
Александр написал:
uasocket, но для нее нет 64 битной версии
дык пересобери под  х64 http://files.luaforge.net/releases/luasocket/luasocket/luasocket-2.0.2/luasocket-2.0.2.tar.gz

Цитата
Александр написал:
От того, что операционные системы 64 битные, это не значит, что весь код должен быть 64 битным.
именно по такой гвн-логике 90% софта - барахло.

Цитата
Александр написал:
Выигрыш от 64 битного перехода не особо виден.
не говори за всех, ок?
 
Цитата
Александр написал:
Во-первых

https://github.com/finsight/QUIKSharp/issues/201
 
будет ли клиент v8 корректно работать с сервером брокера, если брокер пока раздаёт клиентов 7.27.2.1 ? (открытие)
 
Цитата
Павел Bosco написал:
будет ли клиент v8 корректно работать с сервером брокера, если брокер пока раздаёт клиентов 7.27.2.1 ?
Чтото мешает попробовать?
Если не получится - вертать все в зад.
 
как вернуть прежнюю версию?брокер ПСБ.
 
Здравствуйте, Alexei.

Вы можете выполнить откат до предыдущей версии, воспользовавшись файлами подкаталога backup рабочего места QUIK: ...\QUIK\backup\
В этом каталоге Вам необходимо выбрать файлы интересующей Вас предыдущей версии QUIK, и скопировать их в корень терминала ...\QUIK\ с подтверждением замены файлов при копировании.
 
честно говоря,не понял что именно требуется в папке \QUIK\backup\ у меня несколько папок с цифровыми именами -это значит там хранятся предыдущие версии,если я правильно понял.Мне нужно скопировать папку допустим с названием 20190531 или мне нужно зайти в саму папку 20190531 и скопировать файлы все?И где находится корень папки?Как и что нужно делать?
 
если я удалю и заново скачаю на сайте брокера дистрибутив,то мне новая версия будет предоставлена,которая у меня не подходит?
 
Alexei,
Цитата
Alexei написал:
если я удалю и заново скачаю на сайте брокера дистрибутив,то мне новая версия будет предоставлена,которая у меня не подходит?
Предлагаем уточнить этот вопрос непосредственно у Вашего брокера.
 
Подскажите, пожалуйста, как перекомпилировать *.dll для работы с lua под новую версию QUIK, старая не работает по причине своей 32-битности, я правильно понимаю?
 
Цитата
Александр Волфовиц написал:
Подскажите, пожалуйста, как перекомпилировать *.dll для работы с lua под новую версию QUIK, старая не работает по причине своей 32-битности, я правильно понимаю?

Почитайте обсуждение по ссылке
https://forum.quik.ru/messages/forum10/message38653/topic4609/#message38653
 
Раньше  можно было кликнуть на таблицу сделок , кликнуть кнтрл С  и скопировать в эксель .  
Сейчас   Вы ввели  вместо этого кнтр шифт С   -  сделки копируются и выносятся в эксель, но графа  Объём - не суммируется. Цифры переносятся не как цифры,  а как текст или тп.
Как быть?
 
Здравствуйте, maipa.
Для того, чтобы данные переносились в числовом виде, необходимо в настройках терминала по пути "Система" -> "Настройки" -> "Основные настройки" -> "Программа" -> "Буфер обмена" выбрать настройку "Формальное представление данных". Обращаем Ваше внимание, что нужно выбрать только эту настройку, другие выбирать не рекомендуем.
QUIK clients support
 
спасибо!  
 
Какая минимальная оперативка нужна? Что-то ноут странно себя ведёт при запуске...
 
   Так, хитроумные. А где предупреждение что на 32 разрядном виндовс 10 ваше обновленная старая допотопная программа работать не будет. И не то что работать , а вырубит операционку вообще. Это как это так исхитриться сделать.?
А во вторых брокер  при работе на квике 7 не гарантирует безопасность. Это значит пользуйся кто хочет твоим счетом. Ну уж не говоря, что многолетние настройки накрылись тазиком.
 
Цитата
Аркадий написал:
А где предупреждение что на 32 разрядном виндовс 10 ваше обновленная старая допотопная программа работать не будет.
видимо в инструкциях на микроволновки для таких, как ты пишут не засовывать туда голову при включении :))
 
Цитата
новичок написал:
Цитата
Аркадий написал:
А где предупреждение что на 32 разрядном виндовс 10 ваше обновленная старая допотопная программа работать не будет.
видимо в инструкциях на микроволновки для таких, как ты пишут не засовывать туда голову при включении :))
ты уже лет десять эту фигню одну тут копирайтишь,, заняться больше нечем, иди инструкции учись писать.
 
Цитата
Аркадий написал:
А во вторых брокер  при работе на квике 7 не гарантирует безопасность.
Что это значит?
Можно ссылку на текст брокера?
В чем именно он её не гарантирует?
Цитата
Аркадий написал:
А где предупреждение что на 32 разрядном виндовс 10 ваше обновленная старая допотопная программа работать не будет.
Кто сказал что не будет? 7 версия работает как и раньше.
И даже 6 работает.
 
Imersio Arrigo,  Какие ссылки. Когда этот анекдотично маразматичный случай произошел . я написал естестно брокеру, те в тех поддержкупо квику  отфутболили,, техподержка не вкурила в чем дело, начала просить скрины как обычно,  потом видать позвонили в квик, потом написали мне, Мол пользуйтесь последней старой версией, но все риски за пользование  квиком берете на себя.
 
Цитата
Аркадий написал:
Imersio Arrigo,  Какие ссылки. Когда этот анекдотично маразматичный случай произошел . я написал естестно брокеру, те в тех поддержкупо квику  отфутболили,, техподержка не вкурила в чем дело, начала просить скрины как обычно,  потом видать позвонили в квик, потом написали мне, Мол пользуйтесь последней старой версией, но все риски за пользование  квиком берете на себя.
Добрый день.

Уже ответили Вам в соседней ветке, повторимся и здесь: никаких проблем с безопасностью, тем более критичных, в 7-ой версии терминала QUIK нет и быть не может.
 
Здравствуйте, Александр Волфовиц.
Цитата
Александр Волфовиц написал:
Какая минимальная оперативка нужна? Что-то ноут странно себя ведёт при запуске...

Системные требования относительно ОЗУ для терминала не изменились: минимально необходимо 2 ГБ ОЗУ, но для комфортной работы рекомендуется не менее 4 ГБ.

Для детального изучения возможных причин Ваших неудобств и их исключения - предлагаем написать нам на quiksupport@arqatech.com. В письме просим сообщить следующую информацию.
Уточните пожалуйста характер поведения вашего ноутбука и / или терминала, которые вызывают у Вас беспокойство. Также просим сообщить характеристики системы и потребляемые терминалом ресурсы.
 
У меня тоже с переходом на x64 стали постоянно появляться сообщения о нехватке оперативной памяти и предложением закрыть эту программу к эдакой матери.  

на квике 7 и ранее ни разу такого сообщения не видел.  
 
Цитата
s_mike@rambler.ru написал:
У меня тоже с переходом на x64 стали постоянно появляться сообщения о нехватке оперативной памяти
А процесс действительно пожирает всю доступную память? Или может это ваши х64-роботы валят Квик? Например неправильно собранная Lua?
 
Цитата
Imersio Arrigo написал:
Цитата
   s_mike@rambler.ru написал:
У меня тоже с переходом на x64 стали постоянно появляться сообщения о нехватке оперативной памяти
А процесс действительно пожирает всю доступную память? Или может это ваши х64-роботы валят Квик? Например неправильно собранная Lua?
нет смысла в фантазиях. Сообщение о нехватке памяти скорее адресовано разработчикам,  как стороне,  способной повлиять на ситуацию.  
 
Здравствуйте. Случайно обновил приложение до 64 разрядной. А операционка у меня 32 разрядная. Теперь не войти в приложение? Как вернуться на 32 разрядную версию???
 
И в каких файлах хранятся настройки рабочих окон квика?
 
Здравствуйте, Герман.
Цитата
Герман написал:
Здравствуйте. Случайно обновил приложение до 64 разрядной. А операционка у меня 32 разрядная. Теперь не войти в приложение? Как вернуться на 32 разрядную версию???
Вы можете выполнить восстановление предыдущей версии путём копирования файлов подкаталога QUIK\backup\XXXXXXXX в QUIK\ с подтверждением замены, где XXXXXXXX - дата создания резервной копии файлов терминала.
Также Вы можете выполнить чистую установку предыдущей версии терминала с использованием установочного файла. Установочный файл терминала интересующей Вас версии - Вы можете найти по этой ссылке на сайте aqratech.com .
Цитата
Герман написал:
И в каких файлах хранятся настройки рабочих окон квика?
Настройки рабочего пространства терминала хранятся в файлах с расширением *.wnd. По умолчанию - терминал использует файл info.wnd, однако Вы можете использовать *.wnd с любым называнием.
 
Спасибо. А работоспособность 32 разрядной версии еще долго будет?
 
Герман,
Цитата
Герман написал:
Спасибо. А работоспособность 32 разрядной версии еще долго будет?
Если Вы подразумеваете вопрос "когда будет вновь будет реализована поддержка архитектуры x32?", то на момент Вашего обращения ответ можно сформулировать следующим образом:
Возобновления поддержки архитектуры x32 не будет.

Если же Вас интересует то, как долго ещё можно будет работать на версиях старше 8.0 - то на этот вопрос, в настоящем, однозначный ответ дать весьма затруднительно.

На момент Вашего обращения, реализация обновлённого ПО выполняется таким образом, который позволяет пользователю работать с устаревшими версиями терминала. Например, нам известны случаи использования версий 6.x и даже 5.x. Тем не менее, иногда, для некоторых пользователей имеют место такие затруднения, единственное решение которых - обновление до приемлемой более новой версии. Причин для таких ситуаций может достаточно много, начиная от дизайна новых версий ПО QUIK на стороне сервера брокера, так и заканчивая параметрами и настроек ОС ПК пользователя.

Информации о том, когда полностью будет прекращена поддержка каких-то конкретных устаревших версий терминала - на момент обращения и формирования данного ответа - нет. Пользователь сам решает - приемлемо ли для него работать на устаревшей версии терминала, или всё же имеет смысл обновиться.
 
А работоспособность 32 разрядной версии еще долго будет?

Никак не привыкну к "функционалу"  этого форума.
Тем не менее имею желание сообщить, что интересы брокеров (читай, прямых покупателей продукта ARQA) могут весьма различаться с хотелками самой ARQA.
Посему, ...  мы  ... ВСЕГДА  . . .  приделывали костыли к тому, чего нам "предоставила" ARQA.
Костыли - уже, -- наши, чего мы теряем?
Как понимаю, своих траблов в V7, они в V7 "признавать" больше не будут, что ВОВСЕ не означает, что брокеры НЕ БУДУТ поддерживать серверы на V6 и V7. . .     ИЛИ . . . ARQA "думает" иначе  . . . ?
Как, резюме,  . . . ситуация принципиально хуже НЕ СТАЛА.
 
А уже есть список брокеров, которые перешли на 64 бит? У меня Сбербанк. До сих пор 32 бита.
 
Здравствуйте, timber.
Цитата
timber написал:
А уже есть список брокеров, которые перешли на 64 бит? У меня Сбербанк. До сих пор 32 бита.
О возможности обновления терминала - предлагаем обратиться непосредственно к Вашему брокеру. Если в процессе / после обновления у Вас возникнут какие-либо затруднения - просим написать нам на quiksupport@arqatech.com для разрешения возникшей ситуации.
 
Здравствуйте.
1. Почему прекратили экспорт данных в систему ТА Metastock?
Через DDE можно, конечно, экспортировать, но это очень неудобно... и нет возможности закачать исторические данные.
И утилиту DDE2MS уже нигде не найти. Если у вас есть - скиньте, пожалуйста, в почтовый ящик.
2. Будет ли в 8-й версии QUIK  
- экспорт через DDE ?
- импорт транзакций через API  и библиотеку Trans2QUIK.dll ?
Спасибо.
 
Добрый день.
По поводу поддержки Метастока Вам нужно обратиться к брокеру.
Утилиты DDE2MS у нас нет.
В 8 версии в части экспорта по DDE и API ничего не менялось, т.е все работает.
 
Цитата
Alexey Ivannikov написал:
Рабочее место QUIK версии 8.0 является 64-разрядным приложением. Перед тем как запускать обновление на новую версию, необходимо обязательно ознакомиться со следующими особенностями новой версии.1. Новая версия может некорректно работать с LUA-скриптами, использующими внешние библиотеки dll. Перед обновлением рекомендуем обратиться к разработчикам скриптов за их обновлением.
Как раз возникла соответствующая проблема, уже хотел было открывать тему но прочитав это понимаю что видимо в этом дело, и что же теперь делать?
А проблема вот в чём - Имеется QUIK 7.27.1.18, в нём все норм работает, захотел немного потренироваться на демо счете от arqatech, скачал самый последний QUIK Junior 8.0
установил, перенес из QUIK 7.27.1.18 в новый QUIK Junior 8.0 скрипт и все его сторонние библиотеки в по точно таким же путям в в квик юниор, при запуске скрипта вылетает ошибка - error loading module 'socket.core' from file 'Z:\QUIK-Junior\lua\ssl\socket\core.dll':
    не является приложением Win32.
То есть в QUIK 7.27.1.18 все тоже самое лежит по точно таким же путям и все работает нормально

Что теперь делать?
 
Нужно пересобирать из исходных тестов библиотеку socket под x64
 
Цитата
s_mike@rambler.ru написал:
Нужно пересобирать из исходных тестов библиотеку socket под x64
Логично, но проще пока забить на новый 64х разр. квик и пользоваться старым добрым 32х разрядным )))
 
Цитата
s_mike@rambler.ru написал:
Нужно пересобирать из исходных тестов библиотеку socket под x64
Так как персобирать придется не только socket а вообще все дополнительно используемые, это только на socket вылетает ошибка потому как эта библ. стоит первой подключаемой в скрипте, после ошибки дальше выполнение скрипта не идет есс-но,  а за ней и другие библы идут, да и дальше там еще неизвестно что может приключится
 
Здравствуйте!

Есть возможность поставить Quik v8.0 на Mac посредством PlayOnMac ?  
 
Здравствуйте, Kolossi.
Да, терминал QUIK 8.0 может быть установлен на компьютеры с macOS при помощи PlayOnMac.
С особенностями процесса установки терминала предлагаем ознакомиться в следующей инструкцией.
Обращаем Ваше внимание на то, что терминал QUIK разрабатывается и тестируется под ОС Windows, использование на ПК с другими ОС (например, macOS) может приводить к ошибкам, недокументированным особенностям и др. непредвиденному поведению терминала.
 
Подскажите, ARQATECH теперь совсем переходит на создание только 64х разрядных версий квика? Где можно скачать последний 32х разр. Квик  (не Junior)
 
Цитата
Andrey Bezrukov написал:
Здравствуйте, Kolossi.
Да, терминал QUIK 8.0 может быть установлен на компьютеры с macOS при помощи PlayOnMac.
С особенностями процесса установки терминала предлагаем ознакомиться в следующей  инструкцией .
Обращаем Ваше внимание на то, что терминал QUIK разрабатывается и тестируется под ОС Windows, использование на ПК с другими ОС (например, macOS) может приводить к ошибкам, недокументированным особенностям и др. непредвиденному поведению терминала.
Андрей спасибо за ответ!
Однако в указаной инструкции описана установка 32-битной версии. Такая уже стоит и до 8 не обновляется.
Я так понимаю, что все дело в 32-х битной версии Wine. Стоит последняя 4.11-staging.  
Вообще у кого-нибудь работает 8.0 под wine?
 
Цитата
Kolossi написал:
Я так понимаю, что все дело в 32-х битной версии Wine
Конечно, создавай для квика 64х битный префикс в вайне теперь, а проще накатить винду в виртуалбоксе в своем маке/линухе  и без проблем поставить в неё квик и не заморачиваться
Страницы: Пред. 1 2 3 4 5 След.
Читают тему (гостей: 2)
Наверх