Что за бред с параметрами Lua индикаторов в Quik 8.8???

Страницы: 1
RSS
Что за бред с параметрами Lua индикаторов в Quik 8.8???
 
Почему в Quik 8.8 я не могу установить значение параметра lua индикатора больше 999??? Что за бред??? В 8.2 можно было вводить любые значения!
 
Проблема изучается. Постараемся в ближайшее время дать ответ.
 
Цитата
Сергей написал:
Почему в Quik 8.8 я не могу установить значение параметра lua индикатора больше 999??? Что за бред??? В 8.2 можно было вводить любые значения!
Здравствуйте!

Ошибка, описанная в данном инциденте, будет исправлена в одной из
     очередных версий программы.

     Приносим извинения за причиненные неудобства.
 
Дробные значения тоже не вводятся. Обратите внимание, пожалуйста.
 
Цитата
Сергей написал:
Дробные значения тоже не вводятся. Обратите внимание, пожалуйста.
Это у них не ошибка, а фича :). Целая переписка была на эту тему.
 
Сергей,
Да мы в курсе
 
Хотел бы добавить почти в тему , не создавая новую. Не работает редактирование в индикаторе.Меняю параметр , по логике должен измениться результат , а ничего не меняется . Мозг начал взрываться , все проверил тыщу раз. Все правильно. Пришлось воткнуть message и обнаружилось , что входной параметр не изменяется после редактирования. Индикатор не прилагаю , поскольку он примитивно простой с десяток строк и ломаться там нечему. Больше сочинил в качестве теста для проверки работы некоторых функций для применения  в другом более объемном продукте. И кстати это уже второй случай.

В августе сочинил индикатор и такая же история - не меняется тэг линии , с которой надо брать данные. Я и так и эдак и все никак. Пробовал добавлять функцию OnChangeSettings() и тоже результата ноль
Пришлось делать копии для разных окон с заранее прописанным тэгом индивидуально. То есть вставляешь индивидуальный индикатор и все четко работает. Это конечно очень нехороший косяк.Ну у меня пара десятков окон , а у кого если сотни ?  Версия последняя 8.8.4.3. На предыдущих редактирование  работало четко.
Кстати встроенные работают нормально.
 
Цитата
vladindre написал:
Хотел бы добавить почти в тему , не создавая новую. Не работает редактирование в индикаторе.Меняю параметр , по логике должен измениться результат , а ничего не меняется . Мозг начал взрываться , все проверил тыщу раз. Все правильно. Пришлось воткнуть message и обнаружилось , что входной параметр не изменяется после редактирования. Индикатор не прилагаю , поскольку он примитивно простой с десяток строк и ломаться там нечему. Больше сочинил в качестве теста для проверки работы некоторых функций для применения  в другом более объемном продукте. И кстати это уже второй случай.

В августе сочинил индикатор и такая же история - не меняется тэг линии , с которой надо брать данные. Я и так и эдак и все никак. Пробовал добавлять функцию OnChangeSettings() и тоже результата ноль
Пришлось делать копии для разных окон с заранее прописанным тэгом индивидуально. То есть вставляешь индивидуальный индикатор и все четко работает. Это конечно очень нехороший косяк.Ну у меня пара десятков окон , а у кого если сотни ?  Версия последняя 8.8.4.3. На предыдущих редактирование  работало четко.
Кстати встроенные работают нормально.
Такого не замечал, версия QUIK та же. 1 индикатор на нескольких графиках и на всех разные параметры.
 
Цитата
Александр М написал:
Такого не замечал, версия QUIK та же.
Пока поиски безрезультатны. Загадка не разрешена.
 
дробные верните.
были же дробные, работали ...
 
Цитата
Vlad написал:
дробные верните.
У меня дробные нормально работают.
 
аа... если хочу дробные то в коде вместо 0 надо написать 0.0
ну криво конечно ..., но сойдет
 
vladindre, Добрый день!

У себя данную проблему воспроизвести не можем.

Просим выслать архив рабочего места, скрипт индикатора на котором наблюдается проблема, и подробное описание проблемы на почту нашей
     поддержки (quiksupport@arqatech.com).
 
Цитата
Roman Azarov написал:
Просим выслать архив рабочего места, скрипт индикатора
Добрый день , Roman Azarov ! Сегодня непременно организую. Поражает то , что индикатор -примитив сделанный строго по букварю и из-за него ничего не может быть.
Так , десяток строк конструирования блока рисования стирания линий с  SetValue для использования в другом продукте.  
 
Цитата
Сергей написал:
Почему в Quik 8.8 я не могу установить значение параметра lua индикатора больше 999??? Что за бред??? В 8.2 можно было вводить любые значения!
Сергей, добрый день!

Описанная в данном инциденте ошибка была исправлена в версии 8.9.0 терминала QUIK.
Рекомендуем вам обновить версию программы.
Приносим извинения за причиненные неудобства.
Страницы: 1
Читают тему (гостей: 1)
Наверх