Коллеги как подключить LUA SOCKET к QUIK 9 ?

Страницы: 1
RSS
Коллеги как подключить LUA SOCKET к QUIK 9 ?
 
Выполняю команду

socket=require("socket")

Вылезают вот такие ошибки

no field package.preload['socket']
no file 'C:\VTBC_Broker\QUIK\lua\socket.lua'
no file 'C:\VTBC_Broker\QUIK\lua\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.lua'
no file 'C:\VTBC_Broker\QUIK\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket\init.lua'
no file '.\socket.lua'
no file '.\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.dll'
no file 'C:\VTBC_Broker\QUIK\. .\lib\lua\5.3\socket.dll'
no file 'C:\VTBC_Broker\QUIK\loadall.dll'
 
Цитата
Alex написал:
Выполняю команду

socket=require("socket")

Вылезают вот такие ошибки

no field package.preload['socket']
no file 'C:\VTBC_Broker\QUIK\lua\socket.lua'
no file 'C:\VTBC_Broker\QUIK\lua\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.lua'
no file 'C:\VTBC_Broker\QUIK\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket\init.lua'
no file '.\socket.lua'
no file '.\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.dll'
no file 'C:\VTBC_Broker\QUIK\. .\lib\lua\5.3\socket.dll'
no file 'C:\VTBC_Broker\QUIK\loadall.dll'
проверьте версию dll
в 9 версии квик можно работать с dll Lua 5.3 либо Lua 5.4
 
Нашел в корневой директории файлы:

lua54.dll
lua53.dll
lua5.1.dll
 
Цитата
nikolz написал:
Цитата
Alex написал:
Выполняю команду

socket=require("socket")

Вылезают вот такие ошибки

no field package.preload['socket']
no file 'C:\VTBC_Broker\QUIK\lua\socket.lua'
no file 'C:\VTBC_Broker\QUIK\lua\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.lua'
no file 'C:\VTBC_Broker\QUIK\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket.lua'
no file 'C:\VTBC_Broker\QUIK\. .\share\lua\5.3\socket\init.lua'
no file '.\socket.lua'
no file '.\socket\init.lua'
no file 'C:\VTBC_Broker\QUIK\socket.dll'
no file 'C:\VTBC_Broker\QUIK\. .\lib\lua\5.3\socket.dll'
no file 'C:\VTBC_Broker\QUIK\loadall.dll'
проверьте версию dll
в 9 версии квик можно работать с dll Lua 5.3 либо Lua 5.4

Надо инсталировать lua socket  или просто кинуть в нужные директории нужные файлы ?
И где их найти? )
 
Если интересно, у меня есть коннектор для С++, в скрипте прописываешь пару строчек, закидываешь 2 папки в директрию с Квиком и через UDP Soket выводишь нужную инфу.
 
Цитата
Alex написал:
Надо инсталировать lua socket  или просто кинуть в нужные директории нужные файлы
Достаточно кинуть в нужные директории

Цитата
Alex написал:
И где их найти? )
Собрать или скачать, если кто-то собрал.
Страницы: 1
Читают тему (гостей: 1)
Наверх