getFuturesLimit на демо возвращает nil

Страницы: 1
RSS
getFuturesLimit на демо возвращает nil
 
На брокерском счёте такой проблемы нет, на демо же, несмотря на то, что в таблице futures_client_limits присутствуют три записи с limit_type=0,3,4, функция getFuturesLimit возвращает только последние две, вместо первое возвращает nil.
Т.е. вызов

getFuturesLimit("SPBFUT000000", "SPBFUT00981", 0)

на демо не работает.
Не то, чтобы это сильно нужно, но как-то неаккуратненько.
 
Цитата
Максим пишет:
На брокерском счёте такой проблемы нет, на демо же, несмотря на то, что в таблице futures_client_limits присутствуют три записи с limit_type=0,3,4, функция getFuturesLimit возвращает только последние две, вместо первое возвращает nil.
Т.е. вызов

getFuturesLimit("SPBFUT000000", "SPBFUT00981", 0)

на демо не работает.
Не то, чтобы это сильно нужно, но как-то неаккуратненько.
Добрый день,

Ваше обращение получено, проблема изучается. Постараемся в ближайшее время дать ответ.
 
Цитата
Максим пишет:
На брокерском счёте такой проблемы нет, на демо же, несмотря на то, что в таблице futures_client_limits присутствуют три записи с limit_type=0,3,4, функция getFuturesLimit возвращает только последние две, вместо первое возвращает nil.
Т.е. вызов

getFuturesLimit("SPBFUT000000", "SPBFUT00981", 0)

на демо не работает.
Не то, чтобы это сильно нужно, но как-то неаккуратненько.
Добрый день,

Ошибка будет исправлена в следующей версии программы.
 
Отлично, теперь эта проблема и у брокера вылезла (Открытие). Видимо он обновил серверную часть? Предлагает обновить терминал до 6.17.3, но я как-то привык сперва проверить новую версию на демо, убедиться что опять что-то не сломали. Но там 6.17.1.17 и обновиться не предлагает. Можно туда 6.17.3 выложить?
 
Цитата
Максим пишет:
Отлично, теперь эта проблема и у брокера вылезла (Открытие). Видимо он обновил серверную часть? Предлагает обновить терминал до 6.17.3, но я как-то привык сперва проверить новую версию на демо, убедиться что опять что-то не сломали. Но там 6.17.1.17 и обновиться не предлагает. Можно туда 6.17.3 выложить?
Добрый день,

Для получения версии рабочего места QUIK 6.17.3 необходимо направить запрос нам на почту: quiksupport@arqatech.com
Обращаем внимание, что данная ошибка будет исправлена в одной из следующих версий программы.
 
Цитата
Stanislav Tvorogov пишет:
Цитата
Максим пишет:
Отлично, теперь эта проблема и у брокера вылезла (Открытие). Видимо он обновил серверную часть? Предлагает обновить терминал до 6.17.3, но я как-то привык сперва проверить новую версию на демо, убедиться что опять что-то не сломали. Но там 6.17.1.17 и обновиться не предлагает. Можно туда 6.17.3 выложить?
Добрый день,

Для получения версии рабочего места QUIK 6.17.3 необходимо направить запрос нам на почту: quiksupport@arqatech.com
Обращаем внимание, что данная ошибка будет исправлена в одной из следующих версий программы.
Просьба зарегистрировать пожелание пересмотреть процесс выпуска новых версий терминала в сторону более раннего их обновления на демо, а уж потом рассылать брокерам. Причина описана выше.
Тем, у кого такая же проблема, вот временное решение (уж не знаю в чём сложность это исправить в той же 6.17.3):

Код
 function getFuturesLimitFixed(firmid, accountid, limit_type)
    local ret = getFuturesLimit(firmid, accountid, limit_type)
    if ret ~= nil then
        return ret
    end
    for i = 0, getNumberOf('futures_client_limits') - 1 do
        local entry = getItem('futures_client_limits', i)
        if entry.firmid == firmid and entry.trdaccid == accountid and entry.limit_type == limit_type then
            return entry
        end
    end

    return nil
end

 
Цитата
Максим пишет:
На брокерском счёте такой проблемы нет, на демо же, несмотря на то, что в таблице futures_client_limits присутствуют три записи с limit_type=0,3,4, функция getFuturesLimit возвращает только последние две, вместо первое возвращает nil.
Т.е. вызов

getFuturesLimit("SPBFUT000000", "SPBFUT00981", 0)

на демо не работает.
Не то, чтобы это сильно нужно, но как-то неаккуратненько.
Добрый день,

Описанная в данном инциденте ошибка была исправлена в версии 7.0.0 терминала QUIK.
Данная версия терминала была выслана всем брокерам, использующим систему QUIK вчера, 07.10.2015, в установленном порядке передачи обновлений .
Рекомендуем Вам дождаться обновления версии терминала у Вашего брокера и обновить Ваш терминал.

Приносим извинения за причиненные неудобства.
Страницы: 1
Читают тему (гостей: 1)
Наверх