таблица Доступные скрипты 8.5.2.11

Страницы: 1
RSS
таблица Доступные скрипты 8.5.2.11, таблица Доступные скрипты 8.5.2.11
 
Квик 8.5.2.11. Беда прямо с этой таблицей. Уважаемые разработчики пожалуйста приведите в порядок. Добавляем несколько скриптов - при удалении из "середины" - начинается "карусель". При добавлении скрипта - пишет что этот скрипт уже есть. В общем там много сюрпризов. Это касается и демо и реала.
 
Заодно добавьте возможность менять порядок скриптов. 21й век а в программе до сих пор окно со скриптами не масштабируется и нет возможно поменять порядок скриптов
 
Как то так получилось - в таблице один скрипт запущен, а в квике 2 работают.
 
Цитата
Sergey Denegin написал:
Заодно добавьте возможность менять порядок скриптов. 21й век а в программе до сих пор окно со скриптами не масштабируется и нет возможно поменять порядок скриптов
Здравствуйте!

Ваше пожелание зарегистрировано.  Мы постараемся рассмотреть его и  сообщить Вам результаты анализа. Впоследствии, по результатам анализа,  будет приниматься решение о реализации пожелания в будущих версиях ПО.
 
Цитата
Egor Zaytsev написал:
Ваше пожелание зарегистрировано.
Этот колхоз имени 8 марта меня искренне поражает.
 
Цитата
swerg написал:
Этот колхоз имени 8 марта меня искренне поражает.
Я сам коды пишу на Lua. Прекрасно понимаю что такое процесс написания. В процессе - ошибки есть и будут - это нормально, но на выходе проверка идет тотальная - проверятся все от и до - чтобы все работало как надо. Понятное дело что все мы люди и ошибки какие то могут быть допущены. НО здесь то явно не скрытая ошибка которую тяжело выявить, здесь реальный косяк на лицо.
Удалил все скрипты из таблица Загруженные скрипты - выключил терминал - включил - все скрипты на месте как будто и не удалял.
Я пишу здесь не с целью критики или обвинений, а с целью обращения вашего внимания на явный недочет и скорейшее устранение этих неполадок.
 
Цитата
Константин Рейм написал:
Цитата
swerg написал:
Этот колхоз имени 8 марта меня искренне поражает.
Я сам коды пишу на Lua. Прекрасно понимаю что такое процесс написания. В процессе - ошибки есть и будут - это нормально, но на выходе проверка идет тотальная - проверятся все от и до - чтобы все работало как надо. Понятное дело что все мы люди и ошибки какие то могут быть допущены. НО здесь то явно не скрытая ошибка которую тяжело выявить, здесь реальный косяк на лицо.
Удалил все скрипты из таблица Загруженные скрипты - выключил терминал - включил - все скрипты на месте как будто и не удалял.
Я пишу здесь не с целью критики или обвинений, а с целью обращения вашего внимания на явный недочет и скорейшее устранение этих неполадок.
Добрый день.

С данным вопросом нужно разбираться.

Проверили у себя, работает корректно. Возможно не хватает прав. Информация о скриптах хранится в файле scripts.dat.
Попробуйте запустить QUIK от имени администратора, нажав правой кнопкой мыши по ярлыку с программой и выбрав "запуск от имени администратора"
 
Цитата
Константин Рейм написал:
Я сам коды пишу на Lua.
начните кодить на С++ и ужаснитесь  :wink:

а до тех пор не критикуйте ржавый авианосец проплывая мимо на катамаране  :!:  
 
Цитата
Egor Zaytsev написал:
С данным вопросом нужно разбираться. Попробуйте запустить QUIK от имени администратора, нажав правой кнопкой мыши по ярлыку с программой и выбрав "запуск от имени администратора"
Картина та же. Запустил 4 скрипта. 1,2,3,4. 2й - удалил. На место 2ого встал 3й скрипт, на место 3ого - 4й - все правильно, но только "зеленые треугольники" - осталось = 4. Далее удалил все скрипты - в терминале в РАБОЧЕМ состоянии остался один скрипт, при этом в поле Загруженные скрипты - НЕТ ни одного скрипта. Попытался добавить вновь удаленный скрипт пишет - "Выбранный скрипт уже был загружен. Добавить его еще раз?"
На первом добавлении скриптов - 3й скрипт с ошибкой - специально посмотреть на вывод ошибки - да выводит ошибку в поле "Ошибки выполнения скрипта" - все хорошо. После удаления из "Доступные скрипты" всех скриптов и повторном добавлении - 3ого (с ошибкой) скрипта - в поле "Ошибки выполнения скрипта" - сообщения об ошибке нет. Удалил все скрипты - закрыл терминал - открыл терминал - все ранее добавленные скрипты - оказались загруженными.
Заходил от имени администратора как вы и предложили.
 
Цитата
Константин Рейм написал:
Цитата
Egor Zaytsev написал:
С данным вопросом нужно разбираться. Попробуйте запустить QUIK от имени администратора, нажав правой кнопкой мыши по ярлыку с программой и выбрав "запуск от имени администратора"
Картина та же. Запустил 4 скрипта. 1,2,3,4. 2й - удалил. На место 2ого встал 3й скрипт, на место 3ого - 4й - все правильно, но только "зеленые треугольники" - осталось = 4. Далее удалил все скрипты - в терминале в РАБОЧЕМ состоянии остался один скрипт, при этом в поле Загруженные скрипты - НЕТ ни одного скрипта. Попытался добавить вновь удаленный скрипт пишет - "Выбранный скрипт уже был загружен. Добавить его еще раз?"
На первом добавлении скриптов - 3й скрипт с ошибкой - специально посмотреть на вывод ошибки - да выводит ошибку в поле "Ошибки выполнения скрипта" - все хорошо. После удаления из "Доступные скрипты" всех скриптов и повторном добавлении - 3ого (с ошибкой) скрипта - в поле "Ошибки выполнения скрипта" - сообщения об ошибке нет. Удалил все скрипты - закрыл терминал - открыл терминал - все ранее добавленные скрипты - оказались загруженными.
Заходил от имени администратора как вы и предложили.
Если сделать так. Добавьте скрипты в таблицу. Закройте QUIK, удалите файла scripts.dat (из директории с программой) запустите QUIK проверьте таблицу "Доступные скрипты".

Сообщите результат.
 
Цитата
Egor Zaytsev написал:
Добавьте скрипты в таблицу. Закройте QUIK, удалите файла scripts.dat (из директории с программой) запустите QUIK проверьте таблицу "Доступные скрипты". Сообщите результат.
Добавил, закрыл, удалил, запустил, проверил - "Доступные скрипты" - пустая таблица.
 
Цитата
Константин Рейм написал:
Цитата
Egor Zaytsev написал:
Добавьте скрипты в таблицу. Закройте QUIK, удалите файла scripts.dat (из директории с программой) запустите QUIK проверьте таблицу "Доступные скрипты". Сообщите результат.
Добавил, закрыл, удалил, запустил, проверил - "Доступные скрипты" - пустая таблица.
В таком случае потребуется ваше рабочее место (без ключей) и скрипт или парочку на которых возникает проблема.

Прислать можно на quiksupport@arqatech.com
 
Цитата
Egor Zaytsev написал:
В таком случае потребуется ваше рабочее место (без ключей) и скрипт или парочку на которых возникает проблема.
Вот здесь такая же проблема
https://forum.quik.ru/messages/forum10/message45090/topic5348/#message45090
а следовательно, дело не в моем терминале и тем более не в моих скриптах.
 
#18 - пост наглядный скрин
 
Цитата
Константин Рейм написал:
#18 - пост наглядный скрин
Здравствуйте!

Ваше обращение получено, проблема изучается. Постараемся в ближайшее время дать ответ.
 
Цитата
Egor Zaytsev написал:
Цитата
Константин Рейм написал:
#18 - пост наглядный скрин
Здравствуйте!

Ваше обращение получено, проблема изучается. Постараемся в ближайшее время дать ответ.

Добрый день,
     
      Действительно есть ошибка удаления скрипта в диалоге. Мы исправим       ошибку в ближайшем обновлении ПО. Как временное решение       переоткрывайте диалог скриптов после удаления скрипта.
   

Приносим извинения за доставленные неудобства.

 
Константин Рейм, здравствуйте.

Описанная в данном инциденте ошибка была исправлена в версии 8.6.0 терминала QUIK.
Рекомендуем вам обновить версию программы.
Приносим извинения за причиненные неудобства.
Страницы: 1
Читают тему (гостей: 1)
Наверх