Проблема запуска скрипта на Lua

Страницы: 1
RSS
Проблема запуска скрипта на Lua, Квик не видит core.dll
 
При попытке запуска скрипта  Квик выдаёт ошибку- не видит в каталоге Lua   core.dll .
Хотя по указанному пути этот файл лежит в гордом одиночестве!?
 
Здравствуйте,
Какую ошибку выдает скрипт?
Как происходит обращение в файлу?
 
 При запуске скрипта  таблицы, Lua , загруженные скрипты ,запустить вылетает-  error loading module "socket.core" from file: C:\program Files\Lua\clibs\socket\core.dll     не найден указанный модуль
 
Похожая проблема уже обсуждалась тут
 
Спасибо Вам за отклик.. Постараюсь разобраться... Но не гуд, что даже на начальном уровне возникают подобные проблемы..
 
Добрый день! Пытаюсь подключить модуль socket в луа и получаю аналогичную ошибку. dll и lua файлы положил как прописано в path и cpath. Запускаю код:

package.path="C:\\BCS_Work_m\\QUIK\\luasocket\\lua\\?.lua"
package.cpath=package.cpath..";C:\\BCS_Work_m\\QUIK\\luasocket\\lib\\?.dll"

function main()
local smtp = require("socket.smtp")
message("HI",3)
end

Квик пишет: error loading module 'socket.core' from file 'C:\BCS_Work_m\QUIK\luasocket\lib\socket\core.dll':
Не найден указанный модуль.

При этом core.dll по этому пути есть. Помогите, пожалуйста, разобраться!
 
dmitry dorjiev,
Если бы проблема была в путях, была бы другая ошибка, вида "module 'socket.smtp' not found"
У Вас же, судя по всему, проблема в самой библиотеке.
Попробуйте использовать другую версию.
 
Попробовал еще с одними бинарниками вот отсюда (https://github.com/pkulchenko/ZeroBraneStudio/tree/master/bin). Теперь пишет ошибку:

error loading module 'ssl.https' from file '.\ssl.dll':
Не найдена указанная процедура.

А нету какого-нибудь проверенного набора библиотек, который с квиком точно работает? Я сам компилировать пробовал, но не хватило навыков :(
 
Извиняюсь, это я уже Luasec пытался тестить, сейчас выдает ошибку: Unknown error. Possible unhandled exception.
Так что вопрос остается в силе.
 
dmitry dorjiev,

Определитесь какую именно библиотеку Вы пытаетесь подключить.
Сначала Вы пишите про socket, потом про ssl. Ели уж пробовать то на чем-то одном.
Это нужно хотя-бы для того чтобы вести диалог об одном и том же.
 
Да, про ssl это я не то написал, потом с новой библиотекой пробовал только сокет, ошибка была Unknown error. Possible unhandled exception. Про ssl пожалуйста игнорируйте :).
 
Цитата
dmitry dorjiev написал:
Да, про ssl это я не то написал, потом с новой библиотекой пробовал только сокет, ошибка была Unknown error. Possible unhandled exception. Про ssl пожалуйста игнорируйте :).
В первом случае не находилась не вызываемая библиотека,
а одна из тех, которая используется внутри этой библиотеки.
Чтобы найти , что надо еще используйте прогу depends,
чтобы найти зависимости.
 
Цитата
Николай Камынин написал:
Цитата
dmitry dorjiev   написал:
Да, про ssl это я не то написал, потом с новой библиотекой пробовал только сокет, ошибка была Unknown error. Possible unhandled exception. Про ssl пожалуйста игнорируйте :).
В первом случае не находилась не вызываемая библиотека,
а одна из тех, которая используется внутри этой библиотеки.
Чтобы найти , что надо еще используйте прогу depends,
чтобы найти зависимости.
Про ssl и про core.dll уже не надо, сейчас ошибка Unknown error. Possible unhandled exception. при попытке подгрузить socket (это после того как я поменял бинарники на скачанные из github'a).
 
выложите уже эти файлы куда-то, чтобы скачать и не искать
по возможности постараюсь посмотреть.
 
Цитата
dmitry dorjiev написал:
Цитата
Николай  Камынин   написал:
Цитата
dmitry dorjiev   написал:
Да, про ssl это я не то написал, потом с новой библиотекой пробовал только сокет, ошибка была Unknown error. Possible unhandled exception. Про ssl пожалуйста игнорируйте :).
В первом случае не находилась не вызываемая библиотека,
а одна из тех, которая используется внутри этой библиотеки.
Чтобы найти , что надо еще используйте прогу depends,
чтобы найти зависимости.
Про ssl и про core.dll уже не надо, сейчас ошибка Unknown error. Possible unhandled exception. при попытке подгрузить socket (это после того как я поменял бинарники на скачанные из github'a).
Это сообщение означает, что встретился глюк в коде, который никто из разработчиков не знает , либо не захотел делать на него ловушку.
 
Никаких глюков в кодах ssl.dll и core.dll нет!

Речь идет о бинарниках версий "LuaSocket 3.0-rc1" (core), "LuaSec 0.6" (ssl)  от https://github.com/brunoos/luasec. Взять их в готовом виде можно, например, из последней версии ZeroBraneStudio.

2 часа танцев с бубном и вот ответ:
ssl.dll требует, чтобы libeay32.dll и ssleay32.dll находились в одной папке с lua5.1.dll, причем именно с той dll, что использует QUIK, т.е., например, в C:\sberbank\quik_sms
а core.dll даже не подозревает, что в природе существует lua5.1.dll, ему нужен только lua51.dll !!! Лечение: делаем нужный файл из копии ИМЕННО Квиковского lua5.1.dll.

P.S. Строго говоря, ssl.dll тоже требует именно  lua51.dll, просто у него не вылезает связанная с этим ошибка, т.к. он загружается после core.dll, т.е. когда проблема с lua51.dll уже решена.
Possible unhandled exception выскакивала скорее всего, когда core.dll каким-то образом находил стороннюю lua51.dll (например, от той же ZeroBraneStudio), только вот она не совместима с QLua.
 
А какую вообще задачу вы этими библиотеками решаете?
 
ТЕЛЕГРАМ ПРИКРУЧИВАЕМ  :lol:
Страницы: 1
Читают тему (гостей: 2)
Наверх